CVE-2023-32007
CVE-2023-32007 · Apache Spark: Shell command injection via Spark UI
This page contains facts from public vulnerability sources. Check the original advisory before updating.
** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This issue was disclosed earlier as CVE-2022-33891, but incorrectly claimed version 3.1.3 (which has since gone EOL) would not be affected. NOTE: This vulnerability only affects products that are no longer supported by the maintainer. Users are recommended to upgrade to a supported version of Apache Spark, such as version 3.4.0.
CVSS 8.8 · High · EPSS 76.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache spark
- Versions
- ≥ 3.1.1, < 3.2.2: Affected (semver)
Update to 3.2.2
org.apache.spark:spark-parent_2.12 Maven
- Versions
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- Affected ranges
- ECOSYSTEM: ≥ 3.1.1, < 3.2.2
Update to 3.2.2
pyspark PyPI
- Versions
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- Affected ranges
- ECOSYSTEM: ≥ 3.1.1, < 3.2.2
Update to 3.2.2
pyspark PyPI
- Versions
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- Affected ranges
- ECOSYSTEM: < 3.2.2
Update to 3.2.2