p PatchFirst

CVE-2023-3210

CVE-2023-3210 · Inefficient Regular Expression Complexity in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab affecting all versions starting from 15.11 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. An authenticated user could trigger a denial of service when importing or cloning malicious content.

CVSS 6.5 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.11, < 16.1.5: Affected (semver)
    • ≥ 16.2, < 16.2.5: Affected (semver)
    • ≥ 16.3, < 16.3.1: Affected (semver)

    Update to 16.1.5; Update to 16.2.5; Update to 16.3.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →