CVE-2023-32409
CVE-2023-32409
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The issue was addressed with improved bounds checks. This issue is fixed in watchOS 9.5, tvOS 16.5, macOS Ventura 13.4, iOS 15.7.8 and iPadOS 15.7.8, Safari 16.5, iOS 16.5 and iPadOS 16.5. A remote attacker may be able to break out of Web Content sandbox. Apple is aware of a report that this issue may have been actively exploited.
CVSS 8.6 · High · EPSS 16.5% · In KEV · Fix available
- Published
- Updated
Stack: system
Affected products and versions
macos
- Versions
- ≥ unspecified, < 13.4: Affected (custom)
Update to 13.4
safari
- Versions
- ≥ unspecified, < 16.5: Affected (custom)
Update to 16.5
watchos
- Versions
- ≥ unspecified, < 9.5: Affected (custom)
Update to 9.5
ios and ipados
- Versions
- ≥ unspecified, < 15.7: Affected (custom)
Update to 15.7
ios and ipados
- Versions
- ≥ unspecified, < 16.5: Affected (custom)
Update to 16.5
tvos
- Versions
- ≥ unspecified, < 16.5: Affected (custom)
Update to 16.5
webkit2gtk Debian:12
- Versions
- 2.40.1-1
- 2.40.2-1
- 2.40.2-1~deb11u1
- 2.40.2-1~deb12u1
- 2.40.3-1
- 2.40.3-2
- 2.40.3-2~deb11u1
- 2.40.3-2~deb11u2
- 2.40.3-2~deb12u1
- 2.40.3-2~deb12u2
- 2.40.4-1
- 2.40.5-1
- 2.40.5-1~deb11u1
- 2.40.5-1~deb12u1
- 2.41.4-1
- 2.41.5-1
- 2.41.6-1
- 2.41.90-1
- 2.41.91-1
- 2.41.91-2
- 2.41.92-1
- 2.42.0-1~bpo12+1
- Affected ranges
- ECOSYSTEM: < 2.42.0-1
Update to 2.42.0-1
webkit2gtk Debian:13
- Affected ranges
- ECOSYSTEM: < 2.42.0-1
Update to 2.42.0-1
webkit2gtk Debian:14
- Affected ranges
- ECOSYSTEM: < 2.42.0-1
Update to 2.42.0-1
wpewebkit Debian:12
- Versions
- 2.38.6-1
- 2.39.91-1
- 2.40.0-1
- 2.40.1-1
- 2.40.2-1
- 2.40.2-2
- 2.40.3-1
- 2.40.4-1
- 2.40.5-1
- 2.42.0-1
- 2.42.1-1
- 2.42.2-1
- 2.42.3-1
- 2.42.4-1
- 2.42.5-1
- 2.42.5-1.1
- 2.42.5-1.1~exp1
- 2.42.5-1.2
- 2.42.5-2~exp
- 2.44.1-1
- 2.44.2-1
- 2.44.2-2
- 2.44.3-1
- 2.44.4-1
- 2.46.1-1
- 2.46.2-1
- 2.46.3-1
- 2.46.4-1
- 2.46.5-1
- 2.46.6-1
- 2.48.0-1
- 2.48.1-1
- 2.48.1-2
- 2.48.2-1
- 2.48.3-1
- 2.48.5-1
- 2.48.6-1
- 2.48.6-2
- 2.50.0-1
- 2.50.0-2
- 2.50.1-1
- 2.50.2-1
- 2.50.3-1
- 2.50.4-1
- 2.50.5-1
- 2.50.6-1
- 2.52.0-1
- 2.52.1-1
- 2.52.2-1
- 2.52.2-2
- 2.52.3-1
- 2.52.4-1
- 2.52.5-1
- 2.52.6-1
- 2.54.0-1
- 2.54.0-2
- 2.54.1-1
- 2.54.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wpewebkit Debian:13
- Affected ranges
- ECOSYSTEM: < 2.42.0-1
Update to 2.42.0-1
wpewebkit Debian:14
- Affected ranges
- ECOSYSTEM: < 2.42.0-1
Update to 2.42.0-1
qtwebkit-opensource-src Ubuntu:16.04:LTS
- Versions
- 5.4.2+dfsg-1ubuntu2.1
- 5.5.1+dfsg-2ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
qtwebkit-source Ubuntu:16.04:LTS
- Versions
- 2.3.2-0ubuntu10
- 2.3.2-0ubuntu11
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
qtwebkit-opensource-src Ubuntu:18.04:LTS
- Versions
- 5.9.1+dfsg-5ubuntu1
- 5.9.1+dfsg-5ubuntu3
- 5.212.0~alpha2-5build2
- 5.212.0~alpha2-5build4
- 5.212.0~alpha2-7
- 5.212.0~alpha2-7build2
- 5.212.0~alpha2-7ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
qtwebkit-source Ubuntu:18.04:LTS
- Versions
- 2.3.2-0ubuntu13
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
qtwebkit-opensource-src Ubuntu:20.04:LTS
- Versions
- 5.212.0~alpha3-3
- 5.212.0~alpha3-5
- 5.212.0~alpha3-6
- 5.212.0~alpha3-7
- 5.212.0~alpha4-1
- 5.212.0~alpha4-1ubuntu1
- 5.212.0~alpha4-1ubuntu2
- 5.212.0~alpha4-1ubuntu2.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wpewebkit Ubuntu:20.04:LTS
- Versions
- 2.26.3-1
- 2.26.4-1
- 2.26.4-1build1
- 2.28.0-1
- 2.28.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
qtwebkit-opensource-src Ubuntu:22.04:LTS
- Versions
- 5.212.0~alpha4-12
- 5.212.0~alpha4-13
- 5.212.0~alpha4-14
- 5.212.0~alpha4-14build1
- 5.212.0~alpha4-14ubuntu2
- 5.212.0~alpha4-15ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wpewebkit Ubuntu:22.04:LTS
- Versions
- 2.32.4-1
- 2.34.1-1
- 2.34.2-1
- 2.34.3-1
- 2.34.4-1
- 2.34.5-1
- 2.34.6-1
- 2.36.0-2ubuntu2
- 2.36.0-2ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
qtwebkit-opensource-src Ubuntu:24.04:LTS
- Versions
- 5.212.0~alpha4-33
- 5.212.0~alpha4-33build1
- 5.212.0~alpha4-34
- 5.212.0~alpha4-34ubuntu3
- 5.212.0~alpha4-34ubuntu4
- 5.212.0~alpha4-36
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://support.apple.com/en-us/HT213758
- https://support.apple.com/en-us/HT213762
- https://support.apple.com/en-us/HT213764
- https://support.apple.com/en-us/HT213842
- https://support.apple.com/en-us/HT213757
- https://support.apple.com/en-us/HT213761
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-32409
- https://nvd.nist.gov/vuln/detail/CVE-2023-32409