CVE-2023-32692
CVE-2023-32692 · Remote Code Execution Vulnerability in Validation Placeholders
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CodeIgniter is a PHP full-stack web framework. This vulnerability allows attackers to execute arbitrary code when you use Validation Placeholders. The vulnerability exists in the Validation library, and validation methods in the controller and in-model validation are also vulnerable because they use the Validation library internally. This issue is patched in version 4.3.5.
CVSS 9.8 · Critical · EPSS 1.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
codeigniter4
- Versions
- < 4.3.5: Affected
No fix published
codeigniter4/framework Packagist
- Versions
- 4.0.0
- 4.0.0-rc.4
- v4.0.0-alpha.3
- v4.0.0-alpha.4
- v4.0.0-alpha.5
- v4.0.0-beta.1
- v4.0.0-beta.2
- v4.0.0-beta.3
- v4.0.0-beta.4
- v4.0.0-rc.1
- v4.0.0-rc.2
- v4.0.0-rc.2.1
- v4.0.0-rc.3
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.0.5
- v4.1.0
- v4.1.1
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.1.6
- v4.1.7
- v4.1.8
- v4.1.9
- v4.2.0
- v4.2.1
- v4.2.10
- v4.2.11
- v4.2.12
- v4.2.2
- v4.2.3
- v4.2.4
- v4.2.5
- v4.2.6
- v4.2.7
- v4.2.8
- v4.2.9
- v4.3.0
- v4.3.1
- v4.3.2
- v4.3.3
- v4.3.4
- Affected ranges
- ECOSYSTEM: < 4.3.5
Update to 4.3.5