CVE-2023-3291
CVE-2023-3291 · Heap-based Buffer Overflow in gpac/gpac
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Heap-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.2.2.
CVSS 5.1 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gpac/gpac
- Versions
- ≥ unspecified, < 2.2.2: Affected (custom)
Update to 2.2.2
gpac Debian:11
- Versions
- 1.0.1+dfsg1-4
- 1.0.1+dfsg1-4+deb11u1
- 1.0.1+dfsg1-4+deb11u2
- 1.0.1+dfsg1-4+deb11u3
- 1.0.1+dfsg1-5
- 2.0.0+dfsg1-1
- 2.0.0+dfsg1-2
- 2.0.0+dfsg1-4
- 2.2.1+dfsg1-1
- 2.2.1+dfsg1-2
- 2.2.1+dfsg1-3
- 2.2.1+dfsg1-3.1
- 2.2.1+dfsg1-3.1~exp1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:14.04:LTS
- Versions
- 0.5.0+svn4288~dfsg1-1ubuntu1
- 0.5.0+svn4288~dfsg1-4
- 0.5.0+svn4288~dfsg1-4ubuntu1
- 0.5.0+svn4288~dfsg1-4ubuntu1+esm1
- 0.5.0+svn4288~dfsg1-4ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:16.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-1build1
- 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
- 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:18.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-3
- 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
- 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:20.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-4ubuntu1
- 0.5.2-426-gc5ad4e4+dfsg5-5
- 0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:22.04:LTS
- Versions
- 1.0.1+dfsg1-4
- 1.0.1+dfsg1-5
- 2.0.0+dfsg1-2
- 2.0.0+dfsg1-2ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:24.04:LTS
- Versions
- 2.2.1+dfsg1-3
- 2.2.1+dfsg1-3.1
- 2.2.1+dfsg1-3.1build1
- 2.2.1+dfsg1-3.1build2
- 2.2.1+dfsg1-3.1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published