p PatchFirst

CVE-2023-33201

CVE-2023-33201

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Bouncy Castle For Java before 1.74 is affected by an LDAP injection vulnerability. The vulnerability only affects applications that use an LDAP CertStore from Bouncy Castle to validate X.509 certificates. During the certificate validation process, Bouncy Castle inserts the certificate's Subject Name into an LDAP search filter without any escaping, which leads to an LDAP injection vulnerability.

CVSS 5.3 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • bouncycastle Debian:12

    Versions
    • 1.72-2
    • 1.77-1
    • 1.80-1
    • 1.80-2
    • 1.80-3
    • 1.86-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • bouncycastle Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.77-1

    Update to 1.77-1

  • bouncycastle Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.77-1

    Update to 1.77-1

  • bouncycastle Ubuntu:Pro:16.04:LTS

    Versions
    • 1.49+dfsg-3ubuntu1
    • 1.51-4ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.51-4ubuntu1+esm1

    Update to 1.51-4ubuntu1+esm1

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Versions
    • 1.57-1
    • 1.58-1
    • 1.59-1
    Affected ranges
    • ECOSYSTEM: < 1.59-1ubuntu0.1~esm1

    Update to 1.59-1ubuntu0.1~esm1

  • bouncycastle Ubuntu:Pro:20.04:LTS

    Versions
    • 1.61-1
    Affected ranges
    • ECOSYSTEM: < 1.61-1ubuntu0.1~esm1

    Update to 1.61-1ubuntu0.1~esm1

  • bouncycastle Ubuntu:Pro:22.04:LTS

    Versions
    • 1.68-2
    • 1.68-4
    • 1.68-5
    Affected ranges
    • ECOSYSTEM: < 1.68-5ubuntu0.1~esm1

    Update to 1.68-5ubuntu0.1~esm1

Original sources

Check your server →