p PatchFirst

CVE-2023-33202

CVE-2023-33202

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Bouncy Castle for Java before 1.73 contains a potential Denial of Service (DoS) issue within the Bouncy Castle org.bouncycastle.openssl.PEMParser class. This class parses OpenSSL PEM encoded streams containing X.509 certificates, PKCS8 encoded keys, and PKCS7 objects. Parsing a file that has crafted ASN.1 data through the PEMParser causes an OutOfMemoryError, which can enable a denial of service attack. (For users of the FIPS Java API: BC-FJA 1.0.2.3 and earlier are affected; BC-FJA 1.0.2.4 is fixed.)

CVSS 5.5 · Medium · EPSS 1.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • bouncycastle Debian:12

    Versions
    • 1.72-2
    • 1.77-1
    • 1.80-1
    • 1.80-2
    • 1.80-3
    • 1.86-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • bouncycastle Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.77-1

    Update to 1.77-1

  • bouncycastle Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.77-1

    Update to 1.77-1

  • bouncycastle Ubuntu:Pro:16.04:LTS

    Versions
    • 1.49+dfsg-3ubuntu1
    • 1.51-4ubuntu1
    • 1.51-4ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Versions
    • 1.57-1
    • 1.58-1
    • 1.59-1
    • 1.59-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • bouncycastle Ubuntu:Pro:20.04:LTS

    Versions
    • 1.61-1
    • 1.61-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • bouncycastle Ubuntu:Pro:22.04:LTS

    Versions
    • 1.68-2
    • 1.68-4
    • 1.68-5
    • 1.68-5ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →