CVE-2023-33234
CVE-2023-33234 · Apache Airflow CNCF Kubernetes Provider: KubernetesPodOperator RCE via connection configuration
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Arbitrary code execution in Apache Airflow CNCF Kubernetes provider version 5.0.0 allows user to change xcom sidecar image and resources via Airflow connection. In order to exploit this weakness, a user would already need elevated permissions (Op or Admin) to change the connection object in this manner. Operators should upgrade to provider version 7.0.0 which has removed the vulnerability.
CVSS 7.2 · High · EPSS 1.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow cncf kubernetes provider
- Versions
- ≥ 5.0.0, ≤ 6.1.0: Affected (semver)
No fix published
apache-airflow-providers-cncf-kubernetes PyPI
- Versions
- 5.0.0
- 5.1.0
- 5.1.0rc1
- 5.1.0rc2
- 5.1.1
- 5.1.1rc1
- 5.2.0
- 5.2.0rc1
- 5.2.1
- 5.2.1rc1
- 5.2.2
- 5.2.2rc1
- 5.3.0
- 5.3.0rc1
- 6.0.0
- 6.0.0rc1
- 6.1.0
- 6.1.0rc1
- 6.2.0rc1
- 7.0.0rc2
- Affected ranges
- ECOSYSTEM: ≥ 5.0.0, < 7.0.0
Update to 7.0.0