CVE-2023-33476
CVE-2023-33476
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ReadyMedia (MiniDLNA) versions from 1.1.15 up to 1.3.2 is vulnerable to Buffer Overflow. The vulnerability is caused by incorrect validation logic when handling HTTP requests using chunked transport encoding. This results in other code later using attacker-controlled chunk values that exceed the length of the allocated buffer, resulting in out-of-bounds read/write.
CVSS 9.8 · Critical · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
minidlna Debian:12
- Versions
- 1.3.0+dfsg-2.2
- Affected ranges
- ECOSYSTEM: < 1.3.0+dfsg-2.2+deb12u1
Update to 1.3.0+dfsg-2.2+deb12u1
minidlna Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.2+dfsg-1.1
Update to 1.3.2+dfsg-1.1
minidlna Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.2+dfsg-1.1
Update to 1.3.2+dfsg-1.1
minidlna Ubuntu:Pro:16.04:LTS
- Versions
- 1.1.4+dfsg-4build1
- 1.1.5+dfsg-1
- 1.1.5+dfsg-2
- 1.1.5+dfsg-2ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 1.1.5+dfsg-2ubuntu0.1+esm1
Update to 1.1.5+dfsg-2ubuntu0.1+esm1
minidlna Ubuntu:Pro:18.04:LTS
- Versions
- 1.2.0+dfsg-2
- 1.2.1+dfsg-1
- 1.2.1+dfsg-1ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 1.2.1+dfsg-1ubuntu0.18.04.1+esm1
Update to 1.2.1+dfsg-1ubuntu0.18.04.1+esm1
minidlna Ubuntu:20.04:LTS
- Versions
- 1.2.1+dfsg-1build1
- 1.2.1+dfsg-1ubuntu0.20.04.1
- Affected ranges
- ECOSYSTEM: < 1.2.1+dfsg-1ubuntu0.20.04.2
Update to 1.2.1+dfsg-1ubuntu0.20.04.2
minidlna Ubuntu:22.04:LTS
- Versions
- 1.3.0+dfsg-2
- 1.3.0+dfsg-2.1
- Affected ranges
- ECOSYSTEM: < 1.3.0+dfsg-2.1ubuntu0.1
Update to 1.3.0+dfsg-2.1ubuntu0.1
Original sources
- https://sourceforge.net/projects/minidlna/
- https://blog.coffinsec.com/0day/2023/05/31/minidlna-heap-overflow-rca.html
- https://sourceforge.net/p/minidlna/git/ci/9bd58553fae5aef3e6dd22f51642d2c851225aec/
- https://lists.debian.org/debian-lts-announce/2023/06/msg00027.html
- https://www.debian.org/security/2023/dsa-5434
- https://security.gentoo.org/glsa/202311-12
- https://nvd.nist.gov/vuln/detail/CVE-2023-33476