p PatchFirst

CVE-2023-3348

CVE-2023-3348 · Directory traversal vulnerability in Cloudflare Wrangler

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Wrangler command line tool  (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.

CVSS 5.7 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • wrangler

    Versions
    • ≥ 3, < 3.1.1: Affected; ≥ 3.1.1: Not affected (semver)
    • ≥ 2, < 2.20.1: Affected; ≥ 2.20.1: Not affected (semver)

    Update to 2.20.1; Update to 3.1.1

  • wrangler npm

    Affected ranges
    • SEMVER: < 2.20.1

    Update to 2.20.1

Original sources

Check your server →