CVE-2023-34232
CVE-2023-34232 · Snowflake NodeJS Driver vulnerable to Command Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
snowflake-connector-nodejs, a NodeJS driver for Snowflake, is vulnerable to command injection via single sign on (SSO) browser URL authentication in versions prior to 1.6.21. In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Version 1.6.21 contains a patch for this issue.
CVSS 7.3 · High · EPSS 1.9% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
snowflake-connector-nodejs
- Versions
- < 1.6.21: Affected
No fix published
snowflake-sdk npm
- Affected ranges
- SEMVER: < 1.6.21
Update to 1.6.21
Original sources
- https://github.com/snowflakedb/snowflake-connector-nodejs/security/advisories/GHSA-h53w-7qw7-vh5c
- https://github.com/snowflakedb/snowflake-connector-nodejs/pull/465
- https://github.com/snowflakedb/snowflake-connector-nodejs/commit/0c9622ae12cd7d627df404b73a783b4a5f60728a
- https://community.snowflake.com/s/article/Node-js-Driver-Release-Notes
- https://nvd.nist.gov/vuln/detail/CVE-2023-34232