p PatchFirst

CVE-2023-3444

CVE-2023-3444 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.3 before 15.11.10, all versions starting from 16.0 before 16.0.6, all versions starting from 16.1 before 16.1.1, which allows an attacker to merge arbitrary code into protected branches.

CVSS 5.7 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.3, < 15.11.10: Affected (semver)
    • ≥ 16.0, < 16.0.6: Affected (semver)
    • ≥ 16.1, < 16.1.1: Affected (semver)

    Update to 15.11.10; Update to 16.0.6; Update to 16.1.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →