p PatchFirst

CVE-2023-36810

CVE-2023-36810 · Quadratic runtime with malformed PDF missing xref marker in pypdf

This page contains facts from public vulnerability sources. Check the original advisory before updating.

pypdf is a pure-python PDF library capable of splitting, merging, cropping, and transforming the pages of PDF files. An attacker who uses this vulnerability can craft a PDF which leads to unexpected long runtime. This quadratic runtime blocks the current process and can utilize a single core of the CPU by 100%. It does not affect memory usage. This issue has been addressed in PR 808 and versions from 1.27.9 include this fix. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 6.2 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • pypdf

    Versions
    • < 1.27.9: Affected

    No fix published

  • pypdf2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.27.9-1

    Update to 1.27.9-1

  • pypdf2 PyPI

    Versions
    • 1.15
    • 1.16
    • 1.17
    • 1.18
    • 1.19
    • 1.20
    • 1.21
    • 1.22
    • 1.23
    • 1.24
    • 1.25
    • 1.25.1
    • 1.26.0
    • 1.27.0
    • 1.27.1
    • 1.27.2
    • 1.27.3
    • 1.27.4
    • 1.27.5
    • 1.27.6
    • 1.27.7
    • 1.27.8
    Affected ranges
    • ECOSYSTEM: < 1.27.9

    Update to 1.27.9

  • pypdf2 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.23+git20141008-1
    • 1.25.1-1
    • 1.25.1-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.25.1-1ubuntu0.1~esm2

    Update to 1.25.1-1ubuntu0.1~esm2

  • pypdf2 Ubuntu:Pro:18.04:LTS

    Versions
    • 1.26.0-2
    • 1.26.0-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.26.0-2ubuntu0.1~esm2

    Update to 1.26.0-2ubuntu0.1~esm2

  • pypdf2 Ubuntu:20.04:LTS

    Versions
    • 1.26.0-2
    • 1.26.0-3ubuntu1
    • 1.26.0-3ubuntu1.20.04.1
    Affected ranges
    • ECOSYSTEM: < 1.26.0-3ubuntu1.20.04.2

    Update to 1.26.0-3ubuntu1.20.04.2

  • pypdf2 Ubuntu:22.04:LTS

    Versions
    • 1.26.0-4
    • 1.26.0-4ubuntu0.22.04.1
    Affected ranges
    • ECOSYSTEM: < 1.26.0-4ubuntu0.22.04.2

    Update to 1.26.0-4ubuntu0.22.04.2

Original sources

Check your server →