CVE-2023-36821
CVE-2023-36821 · Uptime Kuma vulnerable to authenticated remote code execution via malicious plugin installation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Uptime Kuma, a self-hosted monitoring tool, allows an authenticated attacker to install a maliciously crafted plugin in versions prior to 1.22.1, which may lead to remote code execution. Uptime Kuma allows authenticated users to install plugins from an official list of plugins. This feature is currently disabled in the web interface, but the corresponding API endpoints are still available after login. After downloading a plugin, it's installed by calling `npm install` in the installation directory of the plugin. Because the plugin is not validated against the official list of plugins or installed with `npm install --ignore-scripts`, a maliciously crafted plugin taking advantage of npm scripts can gain remote code execution. Version 1.22.1 contains a patch for this issue.
CVSS 8.8 · High · EPSS 2.0% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
uptime-kuma
- Versions
- < 1.22.1: Affected
No fix published
uptime-kuma npm
- Affected ranges
- SEMVER: < 1.22.1
Update to 1.22.1
Original sources
- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-7grx-f945-mj96
- https://github.com/louislam/uptime-kuma/pull/3346
- https://github.com/louislam/uptime-kuma/blob/8c60e902e1c76ecbbd1b0423b07ce615341cb850/server/plugins-manager.js#L210-L216
- https://github.com/louislam/uptime-kuma/releases/tag/1.22.1
- https://nvd.nist.gov/vuln/detail/CVE-2023-36821