p PatchFirst

CVE-2023-36825

CVE-2023-36825 · Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards. A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the `_state` query parameter, which can result in remote code execution. The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds.

CVSS 9.7 · Critical · EPSS 1.1% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • platform

    Versions
    • >= 14.0.0-alpha4, < 14.5.0: Affected

    No fix published

  • orchid/platform Packagist

    Versions
    • 14.0.0
    • 14.0.0-alpha4
    • 14.0.0-alpha5
    • 14.0.0-alpha6
    • 14.0.0-alpha7
    • 14.0.1
    • 14.0.2
    • 14.0.3
    • 14.1.0
    • 14.1.1
    • 14.2.0
    • 14.2.1
    • 14.3.0
    • 14.4.0
    Affected ranges
    • ECOSYSTEM: ≥ 14.0.0-alpha4, < 14.5.0

    Update to 14.5.0

Original sources

Check your server →