CVE-2023-36826
CVE-2023-36826 · Sentry vulnerable to improper authorization on debug and artifact file downloads
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.
CVSS 7.7 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
sentry
- Versions
- >= 8.21.0, < 23.5.2: Affected
No fix published
sentry PyPI
- Versions
- 10.0.0
- 10.0.1
- 20.10.1
- 20.11.0
- 20.11.1
- 20.12.0
- 20.12.1
- 20.6.0
- 20.7.0
- 20.7.1
- 20.7.2
- 20.8.0
- 21.1.0
- 21.10.0
- 21.11.0
- 21.12.0
- 21.2.0
- 21.3.0
- 21.3.1
- 21.4.0
- 21.4.1
- 21.5.0
- 21.5.1
- 21.6.0
- 21.6.1
- 21.6.2
- 21.6.3
- 21.7.0
- 21.8.0
- 21.9.0
- 22.1.0
- 22.10.0
- 22.11.0
- 22.12.0
- 22.2.0
- 22.3.0
- 22.4.0
- 22.5.0
- 22.6.0
- 22.7.0
- 22.8.0
- 22.9.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 23.3.1
- 23.4.0
- 23.5.0
- 23.5.1
- 8.21.0
- 8.22.0
- 9.0.0
- 9.0.0rc1
- 9.1.0
- 9.1.1
- 9.1.2
- Affected ranges
- ECOSYSTEM: ≥ 8.21.0, < 23.5.2
Update to 23.5.2
sentry PyPI
- Versions
- 10.0.0
- 10.0.1
- 20.10.1
- 20.11.0
- 20.11.1
- 20.12.0
- 20.12.1
- 20.6.0
- 20.7.0
- 20.7.1
- 20.7.2
- 20.8.0
- 21.1.0
- 21.10.0
- 21.11.0
- 21.12.0
- 21.2.0
- 21.3.0
- 21.3.1
- 21.4.0
- 21.4.1
- 21.5.0
- 21.5.1
- 21.6.0
- 21.6.1
- 21.6.2
- 21.6.3
- 21.7.0
- 21.8.0
- 21.9.0
- 22.1.0
- 22.10.0
- 22.11.0
- 22.12.0
- 22.2.0
- 22.3.0
- 22.4.0
- 22.5.0
- 22.6.0
- 22.7.0
- 22.8.0
- 22.9.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 23.3.1
- 23.4.0
- 23.5.0
- 23.5.1
- 8.21.0
- 8.22.0
- 9.0.0
- 9.0.0rc1
- 9.1.0
- 9.1.1
- 9.1.2
- Affected ranges
- GIT: < e932b15435bf36239431eaa3790a6bcfa47046a9
- ECOSYSTEM: ≥ 8.21.0, < 23.5.2
Update to 23.5.2