CVE-2023-36827
CVE-2023-36827 · Fides vulnerable to Path Traversal in Webserver API
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`. If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.
CVSS 7.5 · High · EPSS 1.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
fides
- Versions
- < 2.15.1: Affected
No fix published
ethyca-fides PyPI
- Versions
- 1.9.9
- 2.0.0
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.14.0
- 2.14.1
- 2.14.2
- 2.15.0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.9.0
- 2.9.1
- 2.9.2
- Affected ranges
- ECOSYSTEM: < 2.15.1
Update to 2.15.1
ethyca-fides PyPI
- Versions
- 1.9.9
- 2.0.0
- 2.1.0
- 2.10.0
- 2.10.1b2
- 2.10.1b3
- 2.11.0
- 2.11.1b0
- 2.11.1b1
- 2.11.1b2
- 2.11.1b3
- 2.11.1b4
- 2.11.1b5
- 2.11.1b6
- 2.12.0
- 2.12.1
- 2.12.1b0
- 2.12.1b1
- 2.12.1b2
- 2.12.1b3
- 2.12.1b4
- 2.12.2b0
- 2.12.2b1
- 2.12.2b2
- 2.13.0
- 2.13.1b0
- 2.13.1b1
- 2.13.1b2
- 2.14.0
- 2.14.1
- 2.14.1b0
- 2.14.1b1
- 2.14.1b2
- 2.14.2
- 2.14.2b0
- 2.14.3b0
- 2.15.0
- 2.15.1b0
- 2.15.1b1
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.9.0
- 2.9.1
- 2.9.2
- Affected ranges
- GIT: < f526d9ffb176006d701493c9d0eff6b4884e811f
- ECOSYSTEM: < 2.15.1
Update to 2.15.1