CVE-2023-3758
CVE-2023-3758 · Sssd: race condition during authorization leads to gpo policies functioning inconsistently
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A race condition flaw was found in sssd where the GPO policy is not consistently applied for authenticated users. This may lead to improper authorization issues, granting or denying access to resources inappropriately.
CVSS 7.1 · High · EPSS 1.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat enterprise linux 8
- Versions
- ≥ 0:2.9.4-3.el8_10: Not affected (rpm)
No fix published
red hat enterprise linux 8.6 extended update support
- Versions
- ≥ 0:2.6.2-4.el8_6.3: Not affected (rpm)
No fix published
red hat enterprise linux 8.8 extended update support
- Versions
- ≥ 0:2.8.2-4.el8_8.2: Not affected (rpm)
No fix published
red hat enterprise linux 9
- Versions
- ≥ 0:2.9.4-6.el9_4: Not affected (rpm)
No fix published
red hat enterprise linux 9.0 extended update support
- Versions
- ≥ 0:2.6.2-4.el9_0.3: Not affected (rpm)
No fix published
red hat enterprise linux 9.2 extended update support
- Versions
- ≥ 0:2.8.2-5.el9_2.4: Not affected (rpm)
No fix published
red hat virtualization 4 for red hat enterprise linux 8
- Versions
- ≥ 0:2.6.2-4.el8_6.3: Not affected (rpm)
No fix published
red hat enterprise linux 6
No fix published
red hat enterprise linux 7
No fix published
sssd Debian:12
- Versions
- 2.8.2-4
- Affected ranges
- ECOSYSTEM: < 2.8.2-4+deb12u1
Update to 2.8.2-4+deb12u1
sssd Debian:13
- Affected ranges
- ECOSYSTEM: < 2.9.5-1
Update to 2.9.5-1
sssd Ubuntu:Pro:16.04:LTS
- Versions
- 1.12.5-2
- 1.13.1-2
- 1.13.2-1
- 1.13.3-1
- 1.13.4-1
- 1.13.4-1ubuntu1
- 1.13.4-1ubuntu1.1
- 1.13.4-1ubuntu1.2
- 1.13.4-1ubuntu1.5
- 1.13.4-1ubuntu1.6
- 1.13.4-1ubuntu1.7
- 1.13.4-1ubuntu1.8
- 1.13.4-1ubuntu1.9
- 1.13.4-1ubuntu1.10
- 1.13.4-1ubuntu1.11
- 1.13.4-1ubuntu1.12
- 1.13.4-1ubuntu1.13
- 1.13.4-1ubuntu1.14
- 1.13.4-1ubuntu1.15
- 1.13.4-1ubuntu1.15+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
sssd Ubuntu:Pro:18.04:LTS
- Versions
- 1.15.3-2ubuntu1
- 1.15.3-3ubuntu1
- 1.16.0-5ubuntu1
- 1.16.0-5ubuntu2
- 1.16.1-1ubuntu1
- 1.16.1-1ubuntu1.1
- 1.16.1-1ubuntu1.2
- 1.16.1-1ubuntu1.3
- 1.16.1-1ubuntu1.4
- 1.16.1-1ubuntu1.5
- 1.16.1-1ubuntu1.6
- 1.16.1-1ubuntu1.7
- 1.16.1-1ubuntu1.8
- 1.16.1-1ubuntu1.8+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
sssd Ubuntu:20.04:LTS
- Versions
- 2.2.0-4ubuntu1
- 2.2.2-1
- 2.2.2-1ubuntu1
- 2.2.3-1.1ubuntu1
- 2.2.3-2
- 2.2.3-3
- 2.2.3-3ubuntu0.1
- 2.2.3-3ubuntu0.2
- 2.2.3-3ubuntu0.3
- 2.2.3-3ubuntu0.4
- 2.2.3-3ubuntu0.6
- 2.2.3-3ubuntu0.7
- 2.2.3-3ubuntu0.8
- 2.2.3-3ubuntu0.9
- 2.2.3-3ubuntu0.10
- 2.2.3-3ubuntu0.11
- 2.2.3-3ubuntu0.12
- Affected ranges
- ECOSYSTEM: < 2.2.3-3ubuntu0.13
Update to 2.2.3-3ubuntu0.13
sssd Ubuntu:22.04:LTS
- Versions
- 2.4.1-2ubuntu4
- 2.5.2-4ubuntu1
- 2.5.2-4ubuntu3
- 2.5.2-4ubuntu4
- 2.6.1-1ubuntu3
- 2.6.3-1ubuntu3
- 2.6.3-1ubuntu3.1
- 2.6.3-1ubuntu3.2
- Affected ranges
- ECOSYSTEM: < 2.6.3-1ubuntu3.3
Update to 2.6.3-1ubuntu3.3
sssd Ubuntu:24.04:LTS
- Versions
- 2.9.1-2ubuntu2
- 2.9.1-2ubuntu3
- 2.9.2-1ubuntu2
- 2.9.4-1ubuntu1
- 2.9.4-1.1ubuntu3
- 2.9.4-1.1ubuntu5
- 2.9.4-1.1ubuntu6
- Affected ranges
- ECOSYSTEM: < 2.9.4-1.1ubuntu6.1
Update to 2.9.4-1.1ubuntu6.1
Original sources
- https://access.redhat.com/errata/RHSA-2024:1919
- https://access.redhat.com/errata/RHSA-2024:1920
- https://access.redhat.com/errata/RHSA-2024:1921
- https://access.redhat.com/errata/RHSA-2024:1922
- https://access.redhat.com/errata/RHSA-2024:2571
- https://access.redhat.com/errata/RHSA-2024:3270
- https://access.redhat.com/security/cve/CVE-2023-3758
- https://bugzilla.redhat.com/show_bug.cgi?id=2223762
- https://github.com/SSSD/sssd/pull/7302
- https://lists.fedoraproject.org/archives/list/[email protected]/message/RV3HIZI3SURBUQKSOOL3XE64OOBQ2HTK/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/XEP62IDS7A55D5UHM6GH7QZ7SQFOAPVF/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/XMORAO2BDDA5YX4ZLMXDZ7SM6KU47SY5/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00008.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-3758