CVE-2023-38000
CVE-2023-38000 · Auth. Stored Cross-Site Scripting (XSS) vulnerability in WordPress core and Gutenberg plugin via Navigation Links Block
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Auth. Stored (contributor+) Cross-Site Scripting (XSS) vulnerability in WordPress core 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.1.3, from 6.0 through 6.0.5, from 5.9 through 5.9.7 and Gutenberg plugin <= 16.8.0 versions.
CVSS 6.5 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress
- Versions
- ≥ 6.3, ≤ 6.3.1: Affected; ≥ 6.3.2: Not affected (custom)
- ≥ 6.2, ≤ 6.2.2: Affected; ≥ 6.2.3: Not affected (custom)
- ≥ 6.1, ≤ 6.1.3: Affected; ≥ 6.1.4: Not affected (custom)
- ≥ 6.0, ≤ 6.0.5: Affected; ≥ 6.0.6: Not affected (custom)
- ≥ 5.9, ≤ 5.9.7: Affected; ≥ 5.9.8: Not affected (custom)
Update to 5.9.8; Update to 6.0.6; Update to 6.1.4; Update to 6.2.3; Update to 6.3.2
gutenberg
- Versions
- ≥ n/a, ≤ 16.8.0: Affected; ≥ 16.8.1: Not affected (custom)
Update to 16.8.1
wordpress Debian:12
- Versions
- 6.1.1+dfsg1-1
- Affected ranges
- ECOSYSTEM: < 6.1.6+dfsg1-0+deb12u1
Update to 6.1.6+dfsg1-0+deb12u1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 6.3.2+dfsg1-1
Update to 6.3.2+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 6.3.2+dfsg1-1
Update to 6.3.2+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:24.04:LTS
- Versions
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:25.10
- Versions
- 6.7.2+dfsg1-1.1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.10
- Versions
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.04:LTS
- Versions
- 6.7.2+dfsg1-1.1ubuntu1
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://patchstack.com/articles/wordpress-core-6-3-2-security-update-technical-advisory?_s_id=cve
- https://patchstack.com/database/vulnerability/wordpress/wordpress-core-6-3-2-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/gutenberg/wordpress-gutenberg-plugin-16-8-0-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve
- https://nvd.nist.gov/vuln/detail/CVE-2023-38000