p PatchFirst

CVE-2023-3907

CVE-2023-3907 · Improper User Management in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A privilege escalation vulnerability in GitLab EE affecting all versions from 16.0 prior to 16.4.4, 16.5 prior to 16.5.4, and 16.6 prior to 16.6.2 allows a project Maintainer to use a Project Access Token to escalate their role to Owner

CVSS 4.9 · Medium · EPSS 0.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.0, < 16.4.4: Affected (semver)
    • ≥ 16.5, < 16.5.4: Affected (semver)
    • ≥ 16.6, < 16.6.2: Affected (semver)

    Update to 16.4.4; Update to 16.5.4; Update to 16.6.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →