CVE-2023-3917
CVE-2023-3917 · Improper Validation of Specified Type of Input in GitLab
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Denial of Service in pipelines affecting all versions of Gitlab EE and CE prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1 allows attacker to cause pipelines to fail.
CVSS 4.3 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gitlab
- Versions
- ≥ 0, < 16.2.8: Affected (semver)
- ≥ 16.3, < 16.3.5: Affected (semver)
- ≥ 16.4, < 16.4.1: Affected (semver)
Update to 16.2.8; Update to 16.3.5; Update to 16.4.1
gitlab Ubuntu:16.04:LTS
- Versions
- 8.4.3+dfsg-9
- 8.4.3+dfsg-12
- 8.5.8+dfsg-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:24.04:LTS
- Versions
- 14.1.0-1
- 16.1.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:25.10
- Versions
- 16.1.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:26.10
- Versions
- 16.1.3-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:26.04:LTS
- Versions
- 16.1.3-2
- 16.1.3-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published