CVE-2023-39331
CVE-2023-39331
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A previously disclosed vulnerability (CVE-2023-30584) was patched insufficiently in commit 205f1e6. The new path traversal vulnerability arises because the implementation does not protect itself against the application overwriting built-in utility functions with user-defined implementations. Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.
CVSS 7.7 · High · EPSS 1.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
node.js
- Versions
- ≥ 4.0, < 4.*: Affected (semver)
- ≥ 5.0, < 5.*: Affected (semver)
- ≥ 6.0, < 6.*: Affected (semver)
- ≥ 7.0, < 7.*: Affected (semver)
- ≥ 8.0, < 8.*: Affected (semver)
- ≥ 9.0, < 9.*: Affected (semver)
- ≥ 10.0, < 10.*: Affected (semver)
- ≥ 11.0, < 11.*: Affected (semver)
- ≥ 12.0, < 12.*: Affected (semver)
- ≥ 13.0, < 13.*: Affected (semver)
- ≥ 14.0, < 14.*: Affected (semver)
- ≥ 15.0, < 15.*: Affected (semver)
- ≥ 16.0, < 16.*: Affected (semver)
- ≥ 17.0, < 17.*: Affected (semver)
- ≥ 19.0, < 19.*: Affected (semver)
- ≥ 20.0, < 20.8.1: Affected (semver)
Update to 20.8.1