CVE-2023-39352
CVE-2023-39352 · Invalid offset validation leading to Out Of Bound Write in FreeRDP
This page contains facts from public vulnerability sources. Check the original advisory before updating.
FreeRDP is a free implementation of the Remote Desktop Protocol (RDP), released under the Apache license. Affected versions are subject to an invalid offset validation leading to Out Of Bound Write. This can be triggered when the values `rect->left` and `rect->top` are exactly equal to `surface->width` and `surface->height`. eg. `rect->left` == `surface->width` && `rect->top` == `surface->height`. In practice this should cause a crash. This issue has been addressed in versions 2.11.0 and 3.0.0-beta3. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 5.3 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
freerdp
- Versions
- < 2.11.0: Affected
- >= 3.0.0-beta1, < 3.0.0-beta3: Affected
No fix published
freerdp2 Debian:12
- Versions
- 2.10.0+dfsg1-1
- 2.10.0+dfsg1-1.1
- 2.11.2+dfsg1-1
- 2.11.2+dfsg1-1.1~exp1
- 2.11.2+dfsg1-1.1~exp2
- 2.11.5+dfsg1-1
- 2.11.7+dfsg1-1
- 2.11.7+dfsg1-2
- 2.11.7+dfsg1-3
- 2.11.7+dfsg1-4
- 2.11.7+dfsg1-5
- Affected ranges
- ECOSYSTEM: < 2.11.7+dfsg1-6~deb12u1
Update to 2.11.7+dfsg1-6~deb12u1
freerdp2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.0.0~git20170725.1.1648deb+dfsg1-1
- 2.0.0~git20170725.1.1648deb+dfsg1-5
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
- 2.0.0~git20170725.1.1648deb+dfsg1-6
- 2.0.0~git20170725.1.1648deb+dfsg1-6build1
- 2.0.0~git20170725.1.1648deb+dfsg1-7
- 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
- 2.1.1+dfsg1-0ubuntu0.18.04.1
- 2.2.0+dfsg1-0ubuntu0.18.04.1
- 2.2.0+dfsg1-0ubuntu0.18.04.2
- 2.2.0+dfsg1-0ubuntu0.18.04.3
- 2.2.0+dfsg1-0ubuntu0.18.04.4
- 2.2.0+dfsg1-0ubuntu0.18.04.4+esm1
- Affected ranges
- ECOSYSTEM: < 2.2.0+dfsg1-0ubuntu0.18.04.4+esm2
Update to 2.2.0+dfsg1-0ubuntu0.18.04.4+esm2
freerdp2 Ubuntu:20.04:LTS
- Versions
- 2.0.0~git20190204.1.2693389a+dfsg1-1
- 2.0.0~git20190204.1.2693389a+dfsg1-2
- 2.0.0~git20190204.1.2693389a+dfsg1-2build1
- 2.0.0~git20190204.1.2693389a+dfsg1-2build2
- 2.1.1+dfsg1-0ubuntu0.20.04.1
- 2.2.0+dfsg1-0ubuntu0.20.04.1
- 2.2.0+dfsg1-0ubuntu0.20.04.2
- 2.2.0+dfsg1-0ubuntu0.20.04.3
- 2.2.0+dfsg1-0ubuntu0.20.04.4
- 2.2.0+dfsg1-0ubuntu0.20.04.5
- Affected ranges
- ECOSYSTEM: < 2.2.0+dfsg1-0ubuntu0.20.04.6
Update to 2.2.0+dfsg1-0ubuntu0.20.04.6
freerdp2 Ubuntu:22.04:LTS
- Versions
- 2.3.0+dfsg1-2build1
- 2.3.0+dfsg1-2ubuntu1
- 2.3.0+dfsg1-2ubuntu2
- 2.4.1+dfsg1-1
- 2.4.1+dfsg1-1ubuntu1
- 2.4.1+dfsg1-1ubuntu2
- 2.5.0+dfsg1-1
- 2.6.0+dfsg1-1
- 2.6.1+dfsg1-1
- 2.6.1+dfsg1-3
- 2.6.1+dfsg1-3ubuntu1
- 2.6.1+dfsg1-3ubuntu2
- 2.6.1+dfsg1-3ubuntu2.1
- 2.6.1+dfsg1-3ubuntu2.2
- 2.6.1+dfsg1-3ubuntu2.3
- 2.6.1+dfsg1-3ubuntu2.4
- Affected ranges
- ECOSYSTEM: < 2.6.1+dfsg1-3ubuntu2.5
Update to 2.6.1+dfsg1-3ubuntu2.5
Original sources
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-whwr-qcf2-2mvj
- https://github.com/FreeRDP/FreeRDP/blob/63a2f65618748c12f79ff7450d46c6e194f2db76/libfreerdp/gdi/gfx.c#L1219-L1239
- https://lists.fedoraproject.org/archives/list/[email protected]/message/OH2ATH2BKDNKCJAU4WPPXK4SHLE3UJUV/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/A6LLDAPEXRDJOM3PREDDD267SSNT77DP/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/IHMTGKCZXJPQOR5ZD2I4GPDNP2DKRXMF/
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- https://security.gentoo.org/glsa/202401-16
- https://lists.debian.org/debian-lts-announce/2025/02/msg00016.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-39352