CVE-2023-39366
CVE-2023-39366 · Stored Cross-site Scripting in data_sources.php through Device-Name in 'select' input in Cacti
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cacti is an open source operational monitoring and fault management framework. Affected versions are subject to a Stored Cross-Site-Scripting (XSS) Vulnerability allows an authenticated user to poison data stored in the _cacti_'s database. These data will be viewed by administrative _cacti_ accounts and execute JavaScript code in the victim's browser at view-time. The `data_sources.php` script displays the data source management information (e.g. data source path, polling configuration etc.) for different data visualizations of the _cacti_ app. CENSUS found that an adversary that is able to configure a malicious Device name, can deploy a stored XSS attack against any user of the same (or broader) privileges. A user that possesses the _General Administration>Sites/Devices/Data_ permissions can configure the device names in _cacti_. This configuration occurs through `http://<HOST>/cacti/host.php`, while the rendered malicious payload is exhibited at `http://<HOST>/cacti/data_sources.php`. This vulnerability has been addressed in version 1.2.25. Users are advised to upgrade. Users unable to update should manually filter HTML output.
CVSS 6.1 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
cacti
- Versions
- < 1.2.25: Affected
No fix published
cacti Debian:12
- Versions
- 1.2.24+ds1-1
- Affected ranges
- ECOSYSTEM: < 1.2.24+ds1-1+deb12u1
Update to 1.2.24+ds1-1+deb12u1
cacti Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.25+ds1-1
Update to 1.2.25+ds1-1
cacti Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.25+ds1-1
Update to 1.2.25+ds1-1
cacti Ubuntu:Pro:14.04:LTS
- Versions
- 0.8.8b+dfsg-3
- 0.8.8b+dfsg-5
- 0.8.8b+dfsg-5ubuntu0.1
- 0.8.8b+dfsg-5ubuntu0.2
- 0.8.8b+dfsg-5ubuntu0.2+esm1
- 0.8.8b+dfsg-5ubuntu0.2+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
cacti Ubuntu:Pro:16.04:LTS
- Versions
- 0.8.8f+ds1-2
- 0.8.8f+ds1-3
- 0.8.8f+ds1-4
- 0.8.8f+ds1-4ubuntu1
- 0.8.8f+ds1-4ubuntu2
- 0.8.8f+ds1-4ubuntu3
- 0.8.8f+ds1-4ubuntu4
- 0.8.8f+ds1-4ubuntu4.16.04
- 0.8.8f+ds1-4ubuntu4.16.04.1
- 0.8.8f+ds1-4ubuntu4.16.04.2
- 0.8.8f+ds1-4ubuntu4.16.04.2+esm1
- 0.8.8f+ds1-4ubuntu4.16.04.2+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
cacti Ubuntu:Pro:18.04:LTS
- Versions
- 1.1.18+ds1-1
- 1.1.27+ds1-2
- 1.1.27+ds1-3
- 1.1.28+ds1-2
- 1.1.35+ds1-1
- 1.1.36+ds1-1
- 1.1.38+ds1-1
- 1.1.38+ds1-1ubuntu0.1~esm1
- 1.1.38+ds1-1ubuntu0.1~esm3
- 1.1.38+ds1-1ubuntu0.1~esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
cacti Ubuntu:Pro:20.04:LTS
- Versions
- 1.2.4+ds1-2ubuntu3
- 1.2.9+ds1-1ubuntu1
- 1.2.9+ds1-1ubuntu2
- 1.2.10+ds1-1ubuntu1
- 1.2.10+ds1-1ubuntu1+esm1
- 1.2.10+ds1-1ubuntu1.1
- 1.2.10+ds1-1ubuntu1.1+esm1
- 1.2.10+ds1-1ubuntu1.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
cacti Ubuntu:Pro:22.04:LTS
- Versions
- 1.2.16+ds1-2ubuntu1
- 1.2.19+ds1-2ubuntu1
- 1.2.19+ds1-2ubuntu1+esm1
- 1.2.19+ds1-2ubuntu1.1
- 1.2.19+ds1-2ubuntu1.1+esm1
- 1.2.19+ds1-2ubuntu1.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
cacti Ubuntu:24.04:LTS
- Versions
- 1.2.25+ds1-2
- 1.2.26+ds1-1
- 1.2.26+ds1-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/Cacti/cacti/security/advisories/GHSA-rwhh-xxm6-vcrv
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WZGB2UXJEUYWWA6IWVFQ3ZTP22FIHMGN/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/CFH3J2WVBKY4ZJNMARVOWJQK6PSLPHFH/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WOQFYGLZBAWT4AWNMO7DU73QXWPXTCKH/
- https://www.debian.org/security/2023/dsa-5550
- https://nvd.nist.gov/vuln/detail/CVE-2023-39366