p PatchFirst

CVE-2023-3979

CVE-2023-3979 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab affecting all versions starting from 10.6 before 16.2.8, all versions starting from 16.3 before 16.3.5, all versions starting from 16.4 before 16.4.1. It was possible that upstream members to collaborate with you on your branch get permission to write to the merge request’s source branch.

CVSS 3.1 · Low · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 10.6, < 16.2.8: Affected (semver)
    • ≥ 16.3, < 16.3.5: Affected (semver)
    • ≥ 16.4, < 16.4.1: Affected (semver)

    Update to 16.2.8; Update to 16.3.5; Update to 16.4.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →