CVE-2023-40017
CVE-2023-40017 · Geonode Server Side Request Forgery vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GeoNode is an open source platform that facilitates the creation, sharing, and collaborative use of geospatial data. In versions 3.2.0 through 4.1.2, the endpoint `/proxy/?url=` does not properly protect against server-side request forgery. This allows an attacker to port scan internal hosts and request information from internal hosts. A patch is available at commit a9eebae80cb362009660a1fd49e105e7cdb499b9.
CVSS 7.5 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
geonode
- Versions
- >= 3.2.0, <= 4.1.2: Affected
No fix published
geonode PyPI
- Versions
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.3.post1
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.1.post1
- 3.3.2
- 3.3.2.post1
- 3.3.2.post2
- 3.3.3
- 4.0.0
- 4.0.0.post1
- 4.0.0rc0
- 4.0.0rc1
- 4.0.1
- 4.0.2
- 4.0.3
- 4.1.0
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.3.post1
- 4.1.4
- 4.1.5
- Affected ranges
- ECOSYSTEM: ≥ 3.2.0, < 4.2.0
Update to 4.2.0
geonode PyPI
- Versions
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.3.post1
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.1.post1
- 3.3.2
- 3.3.2.post1
- 3.3.2.post2
- 3.3.3
- 4.0.0
- 4.0.0.post1
- 4.0.0rc0
- 4.0.0rc1
- 4.0.1
- 4.0.2
- 4.0.3
- 4.1.0
- 4.1.1
- 4.1.2
- Affected ranges
- GIT: < a9eebae80cb362009660a1fd49e105e7cdb499b9
- ECOSYSTEM: ≥ 3.2.0, < 4.1.3
Update to 4.1.3