CVE-2023-40610
CVE-2023-40610 · Apache Superset: Privilege escalation with default examples database
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper authorization check and possible privilege escalation on Apache Superset up to but excluding 2.1.2. Using the default examples database connection that allows access to both the examples schema and Apache Superset's metadata database, an attacker using a specially crafted CTE SQL statement could change data on the metadata database. This weakness could result on tampering with the authentication/authorization data.
CVSS 6.3 · Medium · EPSS 1.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache superset
- Versions
- ≥ 0, < 2.1.2: Affected (semver)
Update to 2.1.2
apache-superset PyPI
- Versions
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- Affected ranges
- ECOSYSTEM: < 2.1.2
Update to 2.1.2