CVE-2023-40619
CVE-2023-40619
This page contains facts from public vulnerability sources. Check the original advisory before updating.
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
CVSS 9.8 · Critical · EPSS 1.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
phppgadmin Debian:13
- Affected ranges
- ECOSYSTEM: < 7.14.7+dfsg-1
Update to 7.14.7+dfsg-1
phppgadmin Debian:14
- Affected ranges
- ECOSYSTEM: < 7.14.7+dfsg-1
Update to 7.14.7+dfsg-1
phppgadmin Ubuntu:16.04:LTS
- Versions
- 5.1+ds-1
- 5.1+ds-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:18.04:LTS
- Versions
- 5.1+ds-2
- 5.1+ds-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:20.04:LTS
- Versions
- 5.1+ds-4
- 7.12.0+ds-2
- 7.12.0+ds-3
- 7.12.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:22.04:LTS
- Versions
- 7.13.0+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:24.04:LTS
- Versions
- 7.13.0+dfsg-2
- 7.13.0+dfsg-3
- 7.14.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:25.10
- Versions
- 7.14.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:26.10
- Versions
- 7.14.7+dfsg-1build1
- 7.14.8+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:26.04:LTS
- Versions
- 7.14.7+dfsg-1
- 7.14.7+dfsg-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published