CVE-2023-41336
CVE-2023-41336 · Prevent injection of invalid entity ids for "autocomplete" fields in symfony ux-autocomplete
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ux-autocomplete is a JavaScript Autocomplete functionality for Symfony. Under certain circumstances, an attacker could successfully submit an entity id for an `EntityType` that is *not* part of the valid choices. The problem has been fixed in `symfony/ux-autocomplete` version 2.11.2.
CVSS 6.5 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
ux-autocomplete
- Versions
- < 2.11.2: Affected
No fix published
symfony/ux-autocomplete Packagist
- Versions
- v2.10.0
- v2.11.0
- v2.11.1
- v2.2.0
- v2.3.0
- v2.4.0
- v2.5.0
- v2.6.0
- v2.6.1
- v2.7.0
- v2.7.1
- v2.8.0
- v2.8.1
- v2.9.0
- v2.9.1
- Affected ranges
- ECOSYSTEM: < 2.11.2
Update to 2.11.2
Original sources
- https://github.com/symfony/ux-autocomplete/security/advisories/GHSA-4cpv-669c-r79x
- https://github.com/symfony/ux-autocomplete/commit/fabcb2eee14b9e84a45b276711853a560b5d770c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/ux-autocomplete/CVE-2023-41336.yaml
- https://symfony.com/bundles/ux-autocomplete/current/index.html#usage-in-a-form-with-ajax
- https://nvd.nist.gov/vuln/detail/CVE-2023-41336