CVE-2023-41900
CVE-2023-41900 · Jetty's OpenId Revoked authentication allows one request
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.
CVSS 3.5 · Low · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
jetty.project
- Versions
- >= 9.4.21, <= 9.4.51: Affected
- >= 10.0.0, <= 10.0.15: Affected
- >= 11.0.0, <= 11.0.15: Affected
No fix published
jetty9 Debian:12
- Versions
- 9.4.50-4
- Affected ranges
- ECOSYSTEM: < 9.4.50-4+deb12u1
Update to 9.4.50-4+deb12u1
jetty9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.4.52-1
Update to 9.4.52-1
jetty9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.4.52-1
Update to 9.4.52-1
jetty9 Ubuntu:16.04:LTS
- Versions
- 9.2.14-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jetty9 Ubuntu:18.04:LTS
- Versions
- 9.2.22-2
- 9.2.22-3
- 9.2.23-1
- 9.4.15-1~18.04.1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jetty9 Ubuntu:20.04:LTS
- Versions
- 9.4.18-2build2
- 9.4.26-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jetty9 Ubuntu:22.04:LTS
- Versions
- 9.4.39-3
- 9.4.44-2
- 9.4.44-3
- 9.4.44-4
- 9.4.45-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-pwh8-58vv-vw48
- https://github.com/eclipse/jetty.project/pull/9528
- https://github.com/eclipse/jetty.project/pull/9660
- https://www.debian.org/security/2023/dsa-5507
- https://security.netapp.com/advisory/ntap-20231110-0004/
- https://nvd.nist.gov/vuln/detail/CVE-2023-41900