CVE-2023-41913
CVE-2023-41913
This page contains facts from public vulnerability sources. Check the original advisory before updating.
strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code execution via a DH public value that exceeds the internal buffer in charon-tkm's DH proxy. The earliest affected version is 5.3.0. An attack can occur via a crafted IKE_SA_INIT message.
CVSS 9.8 · Critical · EPSS 2.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
strongswan Debian:12
- Versions
- 5.9.8-5
- Affected ranges
- ECOSYSTEM: < 5.9.8-5+deb12u1
Update to 5.9.8-5+deb12u1
strongswan Debian:13
- Affected ranges
- ECOSYSTEM: < 5.9.12-1
Update to 5.9.12-1
strongswan Debian:14
- Affected ranges
- ECOSYSTEM: < 5.9.12-1
Update to 5.9.12-1
strongswan Ubuntu:Pro:16.04:LTS
- Versions
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- 5.3.5-1ubuntu3.8
- 5.3.5-1ubuntu3.8+esm1
- 5.3.5-1ubuntu3.8+esm2
- 5.3.5-1ubuntu3.8+esm3
- Affected ranges
- ECOSYSTEM: < 5.3.5-1ubuntu3.8+esm4
Update to 5.3.5-1ubuntu3.8+esm4
strongswan Ubuntu:Pro:18.04:LTS
- Versions
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- 5.6.2-1ubuntu2.7
- 5.6.2-1ubuntu2.8
- 5.6.2-1ubuntu2.9
- Affected ranges
- ECOSYSTEM: < 5.6.2-1ubuntu2.9+esm1
Update to 5.6.2-1ubuntu2.9+esm1
strongswan Ubuntu:20.04:LTS
- Versions
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- 5.8.2-1ubuntu3.3
- 5.8.2-1ubuntu3.4
- 5.8.2-1ubuntu3.5
- Affected ranges
- ECOSYSTEM: < 5.8.2-1ubuntu3.6
Update to 5.8.2-1ubuntu3.6
strongswan Ubuntu:22.04:LTS
- Versions
- 5.9.1-1ubuntu3
- 5.9.1-1ubuntu3.1
- 5.9.4-1ubuntu1
- 5.9.4-1ubuntu2
- 5.9.4-1ubuntu3
- 5.9.4-1ubuntu4
- 5.9.5-2ubuntu1
- 5.9.5-2ubuntu2
- 5.9.5-2ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 5.9.5-2ubuntu2.2
Update to 5.9.5-2ubuntu2.2
Original sources
- https://github.com/strongswan/strongswan/releases
- https://www.strongswan.org/blog/2023/11/20/strongswan-vulnerability-%28cve-2023-41913%29.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPJZPYHBCRXUQGGKQE6TYH4J4RIJH6HO/
- https://security.netapp.com/advisory/ntap-20250117-0003/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YPJZPYHBCRXUQGGKQE6TYH4J4RIJH6HO/
- https://lists.debian.org/debian-lts-announce/2023/11/msg00018.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-41913