p PatchFirst

CVE-2023-4218

CVE-2023-4218 · XXE in eclipse.platform / Eclipse IDE

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Eclipse IDE versions < 2023-09 (4.29) some files with xml content are parsed vulnerable against all sorts of XXE attacks. The user just needs to open any evil project or update an open project with a vulnerable file (for example for review a foreign repository or patch).

CVSS 5.0 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • eclipse ide

    Versions
    • ≥ 0, < 4.29: Affected (semver)

    Update to 4.29

  • eclipse ide

    Versions
    • ≥ 0, < 2023-09: Affected (custom)

    Update to 2023-09

  • org.eclipse.core.runtime

    Versions
    • ≥ 0, < 3.29.0: Affected (semver)

    Update to 3.29.0

  • org.eclipse.pde

    Versions
    • ≥ 0, ≤ 3.13.2400: Affected (semver)

    No fix published

  • eclipse Ubuntu:16.04:LTS

    Versions
    • 3.8.1-8
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • eclipse Ubuntu:18.04:LTS

    Versions
    • 3.8.1-10
    • 3.8.1-11
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →