p PatchFirst

CVE-2023-42458

CVE-2023-42458 · Zope vulnerable to Stored Cross Site Scripting with SVG images

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Zope is an open-source web application server. Prior to versions 4.8.10 and 5.8.5, there is a stored cross site scripting vulnerability for SVG images. Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link. Patches are available in Zope 4.8.10 and 5.8.5. As a workaround, make sure the "Add Documents, Images, and Files" permission is only assigned to trusted roles. By default, only the Manager has this permission.

CVSS 3.7 · Low · EPSS 0.7% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • zope

    Versions
    • < 4.8.10: Affected
    • >= 5.0.0, < 5.8.5: Affected

    No fix published

  • zope PyPI

    Versions
    • 4.0
    • 4.0b1
    • 4.0b10
    • 4.0b2
    • 4.0b3
    • 4.0b4
    • 4.0b5
    • 4.0b6
    • 4.0b7
    • 4.0b8
    • 4.0b9
    • 4.1
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.2
    • 4.2.1
    • 4.3
    • 4.4
    • 4.4.1
    • 4.4.2
    • 4.4.3
    • 4.4.4
    • 4.5
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.6
    • 4.6.1
    • 4.6.2
    • 4.6.3
    • 4.7
    • 4.8
    • 4.8.1
    • 4.8.2
    • 4.8.3
    • 4.8.4
    • 4.8.5
    • 4.8.6
    • 4.8.7
    • 4.8.8
    • 4.8.9
    Affected ranges
    • ECOSYSTEM: < 4.8.10

    Update to 4.8.10

  • zope PyPI

    Versions
    • 5.8
    • 5.8.1
    • 5.8.2
    • 5.8.3
    • 5.8.4
    Affected ranges
    • ECOSYSTEM: ≥ 5.8.0, < 5.8.5

    Update to 5.8.5

  • zope PyPI

    Versions
    • 4.0
    • 4.0b1
    • 4.0b10
    • 4.0b2
    • 4.0b3
    • 4.0b4
    • 4.0b5
    • 4.0b6
    • 4.0b7
    • 4.0b8
    • 4.0b9
    • 4.1
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.2
    • 4.2.1
    • 4.3
    • 4.4
    • 4.4.1
    • 4.4.2
    • 4.4.3
    • 4.4.4
    • 4.5
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.6
    • 4.6.1
    • 4.6.2
    • 4.6.3
    • 4.7
    • 4.8
    • 4.8.1
    • 4.8.2
    • 4.8.3
    • 4.8.4
    • 4.8.5
    • 4.8.6
    • 4.8.7
    • 4.8.8
    • 4.8.9
    • 5.8
    • 5.8.1
    • 5.8.2
    • 5.8.3
    • 5.8.4
    Affected ranges
    • ECOSYSTEM: < 4.8.10 ∪ ≥ 5.8.0, < 5.8.5

    Update to 4.8.10; Update to 5.8.5

Original sources

Check your server →