p PatchFirst

CVE-2023-44270

CVE-2023-44270

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in PostCSS before 8.4.31. The vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being included in a comment.

CVSS 5.3 · Medium · EPSS 1.0% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • node-postcss Debian:12

    Versions
    • 8.4.20+~cs8.0.23-1
    Affected ranges
    • ECOSYSTEM: < 8.4.20+~cs8.0.23-1+deb12u1

    Update to 8.4.20+~cs8.0.23-1+deb12u1

  • node-postcss Debian:13

    Affected ranges
    • ECOSYSTEM: < 8.4.31+~cs8.0.26-1

    Update to 8.4.31+~cs8.0.26-1

  • node-postcss Debian:14

    Affected ranges
    • ECOSYSTEM: < 8.4.31+~cs8.0.26-1

    Update to 8.4.31+~cs8.0.26-1

  • postcss npm

    Affected ranges
    • SEMVER: < 8.4.31

    Update to 8.4.31

  • node-postcss Ubuntu:20.04:LTS

    Versions
    • 6.0.23-1
    • 6.0.23-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-postcss Ubuntu:22.04:LTS

    Versions
    • 8.2.1+~cs5.3.23-8
    • 8.4.5+~cs7.1.51-2
    • 8.4.6+~cs7.3.21-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-postcss Ubuntu:24.04:LTS

    Versions
    • 8.4.20+~cs8.0.23-1
    • 8.4.31+~cs8.0.26-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-postcss Ubuntu:25.10

    Versions
    • 8.4.49+~cs9.2.32-1
    • 8.5.6+~cs9.3.28-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-postcss Ubuntu:26.10

    Versions
    • 8.5.8+~cs9.3.30-1
    • 8.5.15+~cs9.3.34-1
    • 8.5.15+~cs9.3.38-1
    • 8.5.15+~cs9.3.39-1build1
    • 8.5.25+~cs10.2.23-1
    • 8.5.26+~cs10.2.24-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-postcss Ubuntu:26.04:LTS

    Versions
    • 8.5.6+~cs9.3.28-1
    • 8.5.8+~cs9.3.30-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →