p PatchFirst

CVE-2023-44441

CVE-2023-44441 · GIMP DDS File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GIMP DDS File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of DDS files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-22093.

CVSS 7.8 · High · EPSS 27.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gimp

    Versions
    • GIMP 2.10.34 (revision 2): Affected

    No fix published

  • gimp Debian:12

    Versions
    • 2.10.34-1
    Affected ranges
    • ECOSYSTEM: < 2.10.34-1+deb12u1

    Update to 2.10.34-1+deb12u1

  • gimp Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.10.36-1

    Update to 2.10.36-1

  • gimp Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.10.36-1

    Update to 2.10.36-1

  • gimp-dds Ubuntu:Pro:16.04:LTS

    Versions
    • 3.0.1-1
    Affected ranges
    • ECOSYSTEM: < 3.0.1-1+deb10u1build0.16.04.1~esm1

    Update to 3.0.1-1+deb10u1build0.16.04.1~esm1

  • gimp-dds Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.1-1
    • 3.0.1-1build1
    Affected ranges
    • ECOSYSTEM: < 3.0.1-1+deb10u1build0.18.04.1~esm1

    Update to 3.0.1-1+deb10u1build0.18.04.1~esm1

  • gimp Ubuntu:20.04:LTS

    Versions
    • 2.10.8-2
    • 2.10.14-2
    • 2.10.14-2build1
    • 2.10.14-2ubuntu1
    • 2.10.14-3
    • 2.10.18-1
    Affected ranges
    • ECOSYSTEM: < 2.10.18-1ubuntu0.1

    Update to 2.10.18-1ubuntu0.1

  • gimp-dds Ubuntu:20.04:LTS

    Versions
    • 3.0.1-1build1
    Affected ranges
    • ECOSYSTEM: < 3.0.1-1+deb10u1build0.20.04.1

    Update to 3.0.1-1+deb10u1build0.20.04.1

  • gimp Ubuntu:22.04:LTS

    Versions
    • 2.10.24-2
    • 2.10.28-1
    • 2.10.30-1
    • 2.10.30-1build1
    Affected ranges
    • ECOSYSTEM: < 2.10.30-1ubuntu0.1

    Update to 2.10.30-1ubuntu0.1

  • gimp-dds Ubuntu:22.04:LTS

    Versions
    • 3.0.1-1build1
    Affected ranges
    • ECOSYSTEM: < 3.0.1-1+deb10u1build0.22.04.1

    Update to 3.0.1-1+deb10u1build0.22.04.1

Original sources

Check your server →