p PatchFirst

CVE-2023-44443

CVE-2023-44443 · GIMP PSP File Parsing Integer Overflow Remote Code Execution Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GIMP PSP File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of PSP files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before writing to memory. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-22096.

CVSS 7.8 · High · EPSS 93.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gimp

    Versions
    • GIMP 2.10.34 (revision 2): Affected

    No fix published

  • gimp Debian:12

    Versions
    • 2.10.34-1
    Affected ranges
    • ECOSYSTEM: < 2.10.34-1+deb12u1

    Update to 2.10.34-1+deb12u1

  • gimp Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.10.36-1

    Update to 2.10.36-1

  • gimp Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.10.36-1

    Update to 2.10.36-1

  • gimp Ubuntu:22.04:LTS

    Versions
    • 2.10.24-2
    • 2.10.28-1
    • 2.10.30-1
    • 2.10.30-1build1
    Affected ranges
    • ECOSYSTEM: < 2.10.30-1ubuntu0.1

    Update to 2.10.30-1ubuntu0.1

Original sources

Check your server →