p PatchFirst

CVE-2023-44444

CVE-2023-44444 · GIMP PSP File Parsing Off-By-One Remote Code Execution Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GIMP PSP File Parsing Off-By-One Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of PSP files. Crafted data in a PSP file can trigger an off-by-one error when calculating a location to write within a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-22097.

CVSS 7.8 · High · EPSS 56.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gimp

    Versions
    • GIMP 2.10.34 (revision 2): Affected

    No fix published

  • gimp Debian:12

    Versions
    • 2.10.34-1
    Affected ranges
    • ECOSYSTEM: < 2.10.34-1+deb12u1

    Update to 2.10.34-1+deb12u1

  • gimp Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.10.36-1

    Update to 2.10.36-1

  • gimp Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.10.36-1

    Update to 2.10.36-1

  • gimp Ubuntu:Pro:16.04:LTS

    Versions
    • 2.8.14-1ubuntu2
    • 2.8.14-1.2ubuntu1
    • 2.8.16-1ubuntu1
    • 2.8.16-1ubuntu1.1
    • 2.8.16-1ubuntu1.1+esm1
    • 2.8.16-1ubuntu1.1+esm2
    • 2.8.16-1ubuntu1.1+esm3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gimp Ubuntu:Pro:18.04:LTS

    Versions
    • 2.8.20-1
    • 2.8.20-1.1
    • 2.8.20-2
    • 2.8.22-1
    • 2.8.22-1ubuntu0.1~esm1
    • 2.8.22-1ubuntu0.1~esm2
    • 2.8.22-1ubuntu0.1~esm3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gimp Ubuntu:20.04:LTS

    Versions
    • 2.10.8-2
    • 2.10.14-2
    • 2.10.14-2build1
    • 2.10.14-2ubuntu1
    • 2.10.14-3
    • 2.10.18-1
    Affected ranges
    • ECOSYSTEM: < 2.10.18-1ubuntu0.1

    Update to 2.10.18-1ubuntu0.1

  • gimp Ubuntu:22.04:LTS

    Versions
    • 2.10.24-2
    • 2.10.28-1
    • 2.10.30-1
    • 2.10.30-1build1
    Affected ranges
    • ECOSYSTEM: < 2.10.30-1ubuntu0.1

    Update to 2.10.30-1ubuntu0.1

Original sources

Check your server →