CVE-2023-46104
CVE-2023-46104 · Apache Superset: Allows for uncontrolled resource consumption via a ZIP bomb
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets. This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.
CVSS 6.5 · Medium · EPSS 1.7% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache superset
- Versions
- ≥ 0, < 2.1.3: Affected (semver)
- ≥ 3.0.0, < 3.0.1: Affected (semver)
Update to 2.1.3; Update to 3.0.1
apache-superset PyPI
- Versions
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- Affected ranges
- ECOSYSTEM: < 2.1.2
Update to 2.1.2
apache-superset PyPI
- Versions
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0, < 3.1.0rc1
Update to 3.1.0rc1
apache-superset PyPI
- Versions
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- Affected ranges
- ECOSYSTEM: < 2.1.2 ∪ ≥ 3.0.0, < 3.1.0rc1
Update to 2.1.2; Update to 3.1.0rc1