CVE-2023-46725
CVE-2023-46725 · FoodCoopShop Server-Side Request Forgery vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
FoodCoopShop is open source software for food coops and local shops. Versions starting with 3.2.0 prior to 3.6.1 are vulnerable to server-side request forgery. In the Network module, a manufacturer account can use the `/api/updateProducts.json` endpoint to make the server send a request to an arbitrary host. This means that the server can be used as a proxy into the internal network where the server is. Furthermore, the checks on a valid image are not adequate, leading to a time of check time of use issue. For example, by using a custom server that returns 200 on HEAD requests, then return a valid image on first GET request and then a 302 redirect to final target on second GET request, the server will copy whatever file is at the redirect destination, making this a full SSRF. Version 3.6.1 fixes this vulnerability.
CVSS 8.1 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
foodcoopshop
- Versions
- >= 3.2.0, < 3.6.1: Affected
No fix published
foodcoopshop/foodcoopshop Packagist
- Versions
- v3.2.0
- v3.2.1
- v3.2.2
- v3.3.0
- v3.4.0
- v3.4.1
- v3.4.2
- v3.5.0
- v3.5.1
- v3.6.0
- Affected ranges
- ECOSYSTEM: ≥ 3.2.0, < 3.6.1
Update to 3.6.1
Original sources
- https://github.com/foodcoopshop/foodcoopshop/security/advisories/GHSA-jhww-fx2j-3rf7
- https://github.com/foodcoopshop/foodcoopshop/pull/972
- https://github.com/foodcoopshop/foodcoopshop/commit/0d5bec5c4c22e1affe7fd321a30e3f3a4d99e808
- https://pastebin.com/8K5Brwbq
- https://nvd.nist.gov/vuln/detail/CVE-2023-46725