CVE-2023-47130
CVE-2023-47130 · Unsafe deserialization of user data in yiisoft/yii
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 8.1 · High · EPSS 3.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
yii
- Versions
- < 1.1.29: Affected
No fix published
yiisoft/yii Packagist
- Versions
- 1.1.14
- 1.1.14-rc
- 1.1.15
- 1.1.16
- 1.1.17
- 1.1.18
- 1.1.19
- 1.1.20
- 1.1.21
- 1.1.22
- 1.1.23
- 1.1.24
- 1.1.25
- 1.1.26
- 1.1.27
- 1.1.28
- Affected ranges
- ECOSYSTEM: < 1.1.29
Update to 1.1.29