p PatchFirst

CVE-2023-47265

CVE-2023-47265 · Apache Airflow: DAG Params alllow to embed unchecked Javascript

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users. Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability

CVSS 5.4 · Medium · EPSS 1.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache airflow

    Versions
    • ≥ 2.6.0, < 2.8.0: Affected (semver)

    Update to 2.8.0

  • apache-airflow PyPI

    Versions
    • 2.6.0
    • 2.6.1
    • 2.6.1rc1
    • 2.6.1rc2
    • 2.6.1rc3
    • 2.6.2
    • 2.6.2rc1
    • 2.6.2rc2
    • 2.6.3
    • 2.6.3rc1
    • 2.7.0
    • 2.7.0b1
    • 2.7.0rc1
    • 2.7.0rc2
    • 2.7.1
    • 2.7.1rc1
    • 2.7.1rc2
    • 2.7.2
    • 2.7.2rc1
    • 2.7.3
    • 2.7.3rc1
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.8.0b1

    Update to 2.8.0b1

Original sources

Check your server →