CVE-2023-48705
CVE-2023-48705 · nautobot has XSS potential in custom links, job buttons, and computed fields
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Nautobot is a Network Source of Truth and Network Automation Platform built as a web application All users of Nautobot versions earlier than 1.6.6 or 2.0.5 are potentially affected by a cross-site scripting vulnerability. Due to incorrect usage of Django's `mark_safe()` API when rendering certain types of user-authored content; including custom links, job buttons, and computed fields; it is possible that users with permission to create or edit these types of content could craft a malicious payload (such as JavaScript code) that would be executed when rendering pages containing this content. The maintainers have fixed the incorrect uses of `mark_safe()` (generally by replacing them with appropriate use of `format_html()` instead) to prevent such malicious data from being executed. Users on Nautobot 1.6.x LTM should upgrade to v1.6.6 and users on Nautobot 2.0.x should upgrade to v2.0.5. Appropriate object permissions can and should be applied to restrict which users are permitted to create or edit the aforementioned types of user-authored content. Other than that, there is no direct workaround available.
CVSS 7.1 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
nautobot
- Versions
- < 1.6.6: Affected
- >= 2.0.0, < 2.0.5: Affected
No fix published
nautobot PyPI
- Versions
- 1.0.0
- 1.0.0a1
- 1.0.0a2
- 1.0.0b1
- 1.0.0b2
- 1.0.0b3
- 1.0.0b4
- 1.0.1
- 1.0.2
- 1.0.3
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.2.0
- 1.2.1
- 1.2.10
- 1.2.11
- 1.2.2
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.2.8
- 1.2.9
- 1.3.0
- 1.3.1
- 1.3.10
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.3.9
- 1.4.0
- 1.4.1
- 1.4.10
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.7
- 1.4.8
- 1.4.9
- 1.5.0
- 1.5.1
- 1.5.10
- 1.5.11
- 1.5.12
- 1.5.13
- 1.5.14
- 1.5.15
- 1.5.16
- 1.5.17
- 1.5.18
- 1.5.19
- 1.5.2
- 1.5.20
- 1.5.21
- 1.5.22
- 1.5.23
- 1.5.24
- 1.5.3
- 1.5.4
- 1.5.5
- 1.5.6
- 1.5.7
- 1.5.8
- 1.5.9
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- Affected ranges
- ECOSYSTEM: < 1.6.6
Update to 1.6.6
nautobot PyPI
- Versions
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.0.5
Update to 2.0.5
nautobot PyPI
- Versions
- 1.0.0
- 1.0.0a1
- 1.0.0a2
- 1.0.0b1
- 1.0.0b2
- 1.0.0b3
- 1.0.0b4
- 1.0.1
- 1.0.2
- 1.0.3
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.2.0
- 1.2.1
- 1.2.10
- 1.2.11
- 1.2.2
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.2.8
- 1.2.9
- 1.3.0
- 1.3.1
- 1.3.10
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.3.9
- 1.4.0
- 1.4.1
- 1.4.10
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.7
- 1.4.8
- 1.4.9
- 1.5.0
- 1.5.1
- 1.5.10
- 1.5.11
- 1.5.12
- 1.5.13
- 1.5.14
- 1.5.15
- 1.5.16
- 1.5.17
- 1.5.18
- 1.5.19
- 1.5.2
- 1.5.20
- 1.5.21
- 1.5.22
- 1.5.23
- 1.5.24
- 1.5.3
- 1.5.4
- 1.5.5
- 1.5.6
- 1.5.7
- 1.5.8
- 1.5.9
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- Affected ranges
- {"events": [{"introduced": "0"}, {"fixed": "362850f5a94689a4c75e3188bf6de826c3b012b2"}, {"fixed": "54abe23331b6c3d0d82bf1b028c679b1d200920d"}], "repo": "https://github.com/nautobot/nautobot", "type": "GIT"}
- ECOSYSTEM: ≥ 2.0.0, < 2.0.5 ∪ < 1.6.6
Update to 2.0.5; Update to 1.6.6
Original sources
- https://github.com/nautobot/nautobot/security/advisories/GHSA-cf9f-wmhp-v4pr
- https://github.com/nautobot/nautobot/pull/4832
- https://github.com/nautobot/nautobot/pull/4833
- https://github.com/nautobot/nautobot/commit/362850f5a94689a4c75e3188bf6de826c3b012b2
- https://github.com/nautobot/nautobot/commit/54abe23331b6c3d0d82bf1b028c679b1d200920d
- https://docs.djangoproject.com/en/3.2/ref/utils/#django.utils.html.format_html
- https://docs.djangoproject.com/en/3.2/ref/utils/#django.utils.safestring.mark_safe
- https://nvd.nist.gov/vuln/detail/CVE-2023-48705