p PatchFirst

CVE-2023-49316

CVE-2023-49316

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Math/BinaryField.php in phpseclib 3 before 3.0.34, excessively large degrees can lead to a denial of service.

CVSS 7.5 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • php-phpseclib3 Debian:12

    Versions
    • 3.0.19-1
    Affected ranges
    • ECOSYSTEM: < 3.0.19-1+deb12u1

    Update to 3.0.19-1+deb12u1

  • php-phpseclib3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.34-1

    Update to 3.0.34-1

  • php-phpseclib3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.34-1

    Update to 3.0.34-1

  • phpseclib/phpseclib Packagist

    Versions
    • 3.0.0
    • 3.0.1
    • 3.0.10
    • 3.0.11
    • 3.0.12
    • 3.0.13
    • 3.0.14
    • 3.0.15
    • 3.0.16
    • 3.0.17
    • 3.0.18
    • 3.0.19
    • 3.0.2
    • 3.0.20
    • 3.0.21
    • 3.0.22
    • 3.0.23
    • 3.0.3
    • 3.0.33
    • 3.0.4
    • 3.0.5
    • 3.0.6
    • 3.0.7
    • 3.0.8
    • 3.0.9
    Affected ranges
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.34

    Update to 3.0.34

  • php-phpseclib3 Ubuntu:Pro:22.04:LTS

    Versions
    • 3.0.9-1
    • 3.0.10-1
    • 3.0.12-2
    • 3.0.13-1
    • 3.0.13-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • php-phpseclib3 Ubuntu:24.04:LTS

    Versions
    • 3.0.21-2
    • 3.0.33-1
    • 3.0.34-1
    • 3.0.35-1
    • 3.0.37-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →