CVE-2023-49920
CVE-2023-49920 · Apache Airflow: Missing CSRF protection on DAG/trigger
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected
CVSS 6.5 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- ≥ 2.7.0, < 2.8.0: Affected (semver)
Update to 2.8.0
apache-airflow PyPI
- Versions
- 2.7.0
- 2.7.1
- 2.7.1rc1
- 2.7.1rc2
- 2.7.2
- 2.7.2rc1
- 2.7.3
- 2.7.3rc1
- 2.8.0b1
- 2.8.0rc1
- 2.8.0rc2
- 2.8.0rc3
- 2.8.0rc4
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.8.0
Update to 2.8.0
apache-airflow PyPI
- Versions
- 2.7.0
- 2.7.1
- 2.7.1rc1
- 2.7.1rc2
- 2.7.2
- 2.7.2rc1
- 2.7.3
- 2.7.3rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.8.0b1
Update to 2.8.0b1