p PatchFirst

CVE-2023-52322

CVE-2023-52322

This page contains facts from public vulnerability sources. Check the original advisory before updating.

ecrire/public/assembler.php in SPIP before 4.1.13 and 4.2.x before 4.2.7 allows XSS because input from _request() is not restricted to safe characters such as alphanumerics.

CVSS 6.1 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • spip Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.1.13+dfsg-1

    Update to 4.1.13+dfsg-1

  • spip Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.1.13+dfsg-1

    Update to 4.1.13+dfsg-1

  • spip Ubuntu:Pro:16.04:LTS

    Versions
    • 3.0.20-1
    • 3.0.21-1
    • 3.0.21-1ubuntu1
    • 3.0.21-1ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:Pro:18.04:LTS

    Versions
    • 3.1.4-3
    • 3.1.4-4~deb9u3build0.18.04.1
    • 3.1.4-4~deb9u5build0.18.04.1
    • 3.1.4-4~deb9u5ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:Pro:20.04:LTS

    Versions
    • 3.2.4-1
    • 3.2.5-1
    • 3.2.7-1
    • 3.2.7-1ubuntu0.1
    • 3.2.7-1ubuntu0.1+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:22.04:LTS

    Versions
    • 3.2.11-3
    • 3.2.12-1
    • 4.0.2-1
    • 4.0.4-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →