CVE-2023-5332
CVE-2023-5332 · Dependency on Vulnerable Third-Party Component in GitLab
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
CVSS 5.9 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gitlab
- Versions
- ≥ 9.5.0, < 16.2.8: Affected (semver)
- ≥ 16.3.0, < 16.3.5: Affected (semver)
- ≥ 16.4, < 16.4.1: Affected (semver)
Update to 16.2.8; Update to 16.3.5; Update to 16.4.1
consul Debian:11
- Versions
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:18.04:LTS
- Versions
- 0.6.4~dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:20.04:LTS
- Versions
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:22.04:LTS
- Versions
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published