p PatchFirst

CVE-2023-5356

CVE-2023-5356 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Incorrect authorization checks in GitLab CE/EE from all versions starting from 8.13 before 16.5.6, all versions starting from 16.6 before 16.6.4, all versions starting from 16.7 before 16.7.2, allows a user to abuse slack/mattermost integrations to execute slash commands as another user.

CVSS 7.3 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 8.13, < 16.5.6: Affected (semver)
    • ≥ 16.6, < 16.6.4: Affected (semver)
    • ≥ 16.7, < 16.7.2: Affected (semver)

    Update to 16.5.6; Update to 16.6.4; Update to 16.7.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →