p PatchFirst

CVE-2023-5520

CVE-2023-5520 · Out-of-bounds Read in gpac/gpac

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

CVSS 4.0 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gpac/gpac

    Versions
    • ≥ unspecified, < 2.2.2: Affected (custom)

    Update to 2.2.2

  • gpac Debian:11

    Versions
    • 1.0.1+dfsg1-4
    • 1.0.1+dfsg1-4+deb11u1
    • 1.0.1+dfsg1-4+deb11u2
    • 1.0.1+dfsg1-4+deb11u3
    • 1.0.1+dfsg1-5
    • 2.0.0+dfsg1-1
    • 2.0.0+dfsg1-2
    • 2.0.0+dfsg1-4
    • 2.2.1+dfsg1-1
    • 2.2.1+dfsg1-2
    • 2.2.1+dfsg1-3
    • 2.2.1+dfsg1-3.1
    • 2.2.1+dfsg1-3.1~exp1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gpac Ubuntu:Pro:22.04:LTS

    Versions
    • 1.0.1+dfsg1-4
    • 1.0.1+dfsg1-5
    • 2.0.0+dfsg1-2
    Affected ranges
    • ECOSYSTEM: < 2.0.0+dfsg1-2ubuntu0.1~esm2

    Update to 2.0.0+dfsg1-2ubuntu0.1~esm2

  • gpac Ubuntu:Pro:24.04:LTS

    Versions
    • 2.2.1+dfsg1-3
    • 2.2.1+dfsg1-3.1
    • 2.2.1+dfsg1-3.1build1
    • 2.2.1+dfsg1-3.1build2
    Affected ranges
    • ECOSYSTEM: < 2.2.1+dfsg1-3.1ubuntu0.1~esm2

    Update to 2.2.1+dfsg1-3.1ubuntu0.1~esm2

Original sources

Check your server →