CVE-2023-5692
CVE-2023-5692 · WordPress Core <= 6.4.3 - Sensitive Information Exposure via redirect_guess_404_permalink
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress Core is vulnerable to Sensitive Information Exposure in versions up to, and including, 6.4.3 via the redirect_guess_404_permalink function. This can allow unauthenticated attackers to expose the slug of a custom post whose 'publicly_queryable' post status has been set to 'false'.
CVSS 5.3 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress
- Versions
- ≥ 0, ≤ 6.4.3: Affected (semver)
No fix published
wordpress Debian:12
- Versions
- 6.1.1+dfsg1-1
- 6.1.6+dfsg1-0+deb12u1
- 6.1.9+dfsg1-0+deb12u1
- 6.2+dfsg1-1
- 6.2.1+dfsg1-1
- 6.2.2+dfsg1-1
- 6.3+dfsg1-1
- 6.3.1+dfsg1-1
- 6.3.2+dfsg1-1
- 6.4.1+dfsg1-1
- 6.4.1+dfsg1-1.1
- 6.4.2+dfsg1-1
- 6.4.3+dfsg1-1
- 6.5+dfsg1-1
- 6.5.2+dfsg1-1
- 6.5.3+dfsg1-1
- 6.5.5+dfsg1-1
- 6.6.1+dfsg1-1
- 6.7.2+dfsg1-1
- 6.7.2+dfsg1-1.1
- 6.8.1+dfsg1-1
- 6.8.3+dfsg1-1
- 6.9+dfsg1-1
- 6.9.4+dfsg1-1
- 7.0+dfsg1-1
- 7.0.2+dfsg1-1
- 7.0.3+dfsg1-1
- 7.1+dfsg1-1
- 7.1.1+dfsg1-1
- 7.1.2+dfsg1-1
- 7.1.3+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 6.5+dfsg1-1
Update to 6.5+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 6.5+dfsg1-1
Update to 6.5+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:24.04:LTS
- Versions
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6e6f993b-ce09-4050-84a1-cbe9953f36b1?source=cve
- https://github.com/WordPress/wordpress-develop/blob/6.3/src/wp-includes/canonical.php#L763
- https://developer.wordpress.org/reference/functions/is_post_publicly_viewable/
- https://developer.wordpress.org/reference/functions/is_post_type_viewable/
- https://core.trac.wordpress.org/changeset/57645
- https://nvd.nist.gov/vuln/detail/CVE-2023-5692