p PatchFirst

CVE-2023-5841

CVE-2023-5841 · OpenEXR Heap Overflow in Scanline Deep Data Parsing

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Due to a failure in validating the number of scanline samples of a OpenEXR file containing deep scanline data, Academy Software Foundation OpenEX image parsing library version 3.2.1 and prior is susceptible to a heap-based buffer overflow vulnerability. This issue was resolved as of versions v3.2.2 and v3.1.12 of the affected library.

CVSS 9.1 · Critical · EPSS 1.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • openexr

    Versions
    • ≥ 0, ≤ 3.2.1: Affected (semver)
    • 3.2.2: Not affected
    • 3.1.12: Not affected

    Update to 3.1.12

  • openexr Debian:12

    Versions
    • 3.1.13-1
    • 3.1.13-2
    • 3.1.5-5
    • 3.1.5-5.1
    • 3.1.5-5.1+hurd.1
    • 3.4.14-0.1
    • 3.4.15+ds-1
    • 3.4.16+ds-1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    • 3.5.2+ds-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • openexr Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.1.13-1

    Update to 3.1.13-1

  • openexr Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.1.13-1

    Update to 3.1.13-1

  • openexr Ubuntu:Pro:24.04:LTS

    Versions
    • 3.1.5-5.1
    • 3.1.5-5.1build1
    • 3.1.5-5.1build2
    • 3.1.5-5.1build3
    • 3.1.5-5.1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →